No se pueden instalar los controladores propietarios de ATI en 12.10

Tengo una computadora portátil con la tarjeta gráfica ATI Radeon 6770M HD Hybrid. En Ubuntu 12.04, instalé el controlador fglrx a través de “controladores adicionales” y funcionó. (Incluso puedo cambiar GPUs). Pero en el nuevo Ubuntu 12.10, después de la instalación, Unity no se carga.

Sólo el ratón y el fondo de pantalla. Si inicializo la configuración sudo aticonfig --initial , luego de reiniciarlo, sudo aticonfig --initial una advertencia que dice que estoy en modo de gráficos bajos. ¿Cómo arreglar esto?

Antes usé una fuente de software para instalar los controladores. Pero cuando uso el terminal, recibí esta advertencia:

 update-alternatives: warning: forcing reinstallation of alternative /usr/lib/fglrx/ld.so.conf because link group x86_64-linux-gnu_gl_conf is broken 

Actualización: Presenté un informe de error en Launchpad: https://bugs.launchpad.net/fglrx/+bug/1068661

Comencé con una instalación limpia de 12.10 (no una actualización) Mi tarjeta es una Radeon HD 5450

Lo primero que hice fue instalar las fonts de Linux y los encabezados de Linux.

 sudo apt-get install linux-source sudo apt-get install linux-headers-generic 

Me di cuenta de que muchos de los que tenían tarjetas Nvidia tenían que hacer esto y estoy seguro de que mencioné en alguna parte que también ayudó a los usuarios de ATI.

Como todos los demás, si instalé alguno de los controladores propietarios después de reiniciar, pude iniciar sesión pero perdí la unidad.

Una cosa que noté es que la instalación del controlador no instaló el centro de control Catalyst (no estoy seguro de que sea igual para todos los demás)

Así que instalé el gestor de paquetes Synaptic e instalé fglrx-updates desde allí

introduzca la descripción de la imagen aquí

Ahora se instaló el centro de control Catalyst.

Sin embargo, al reiniciar, en lugar de poder iniciar sesión sin Unity, el sistema estaba colgado en la pantalla de inicio.

Así que apliqué nomodeset y esta vez arrancó con Unity presente

Aquí está el resultado de fglrxinfo

introduzca la descripción de la imagen aquí

Y aquí está lo que dicen las fonts de software.

introduzca la descripción de la imagen aquí

Con el nomodeset aplicado, es posible que no esté nomodeset la pantalla de inicio, pero fglrx-updates funciona bien. Me atrevería a decir que se está desempeñando mejor que en 12.04

Más información

Grub me ofrece 2 kernels

3.5.0-18-genérico y 3.5.0-17-genérico

El último ’18’ es bueno, el anterior ’17’ todavía se carga sin Unidad

Para aquellos que tienen sistemas híbridos (ATI / intel) y fglrx ha dejado de funcionar en 12.10, entonces el problema podría ser como el que se describe aquí (incompatibilidad de fglrx con la versión reciente del controlador intel): https: //bugs.launchpad. net / ubuntu / + source / fglrx-installer-updates / + bug / 1068404

Lo que yo sugeriría sería

  1. Eliminar todos los paquetes fglrx *:

     sudo apt-get purge fglrx* 
  2. Agregue mi PPA en su lista de repositorys:

    sudo add-apt-repository ppa: andrikos

  3. Actualice la información de su paquete:

     sudo apt-get update 
  4. Actualice los controladores fglrx e intel :

     sudo apt-get install fglrx xserver-xorg-video-intel 
  5. No olvides habilitar el driver fglrx

     sudo aticonfig --initial --force 

Fui a la terminal ( Ctrl + Alt + F1 por ejemplo) e hice:

 sudo apt-get remove fglrx 

Ahora mi computadora es bastante lenta, pero al menos puedo usarla y esperar a que se solucione el problema.

Encontré el problema. En la actualización de Ubuntu 12.04 -> Ubuntu 12.10, los contenidos de lightdm.conf en /etc/lightdm/ están completamente borrados. Instalar o reconfigurar lightdm NO instala este archivo aquí, por lo que lightdm no sabe cómo mostrarse. Debes hacer lo siguiente:

 sudo apt-get purge fglrx lightdm && sudo apt-get install lightdm ubuntu-desktop && sudo nano /etc/lightdm/lightdm.conf 

Inserte el siguiente texto:

 [SeatDefaults] user-session=ubuntu greeter-session=unity-greeter allow-guest=false 

Guarde el archivo a través de CTRL + X y reinicie sudo. Puede que no tenga que desinstalar fglrx, pero no lo sé.

Esto funciona para mi

  sudo apt-get install linux-headers-generic 

Vaya a amd.com y descargue su último controlador beta (que se acaba de actualizar a 12.11). Ejecutar e instalar.

Tenga en cuenta que el controlador estable no funcionará con la unidad.

Luego dirígete aquí para obtener un script para eliminar la marca de agua: http://areyoueye.net/?p=187

Slainte!

Hay un error abierto en este momento con fglrx-installer y Ubuntu 12.10

https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/1025488

Siempre digo “buscar errores abiertos y confirmados” antes de continuar con algo, especialmente cuando la distribución es nueva.

Puedes participar en este error si te afecta, publicando comentarios allí y haciendo clic en el botón “Sí, me afecta” (tienes que tener una cuenta de Launchpad).

Solución para mí:

  1. eliminar el actual fglrx sudo sh /usr/share/ati/fglrx-uninstall.sh sudo apt-get remove --purge fglrx*

  2. agregar repository ppa sudo apt-add-repository ppa:andrikos/ppa

  3. lista de paquetes de actualización sudo apt-get update

  4. instalar paquetes sudo apt-get install fglrx-updates

Tengo el mismo problema. ¿Puedo encontrar una posible solución? Primero abrí el Ubuntu-Software-Center y estaba buscando “controladores adicionales”. Después de instalar los “controladores adicionales”, instalé el controlador ATI y después de reiniciar el arranque de mi notebook, normalmente con la unidad y con el controlador propietario correcto.

Nota: la instalación desde el botón Fuentes de software no funcionó en mi caso.