Problemas con monitores externos en mi laptop

Ayer obtuve mi nueva computadora portátil y cambié de Mac OS X a Ubuntu. El chip gráfico es un conjunto de chips Intel 3000 de los nuevos procesadores Sandy Bridge. Ahora, estoy teniendo problemas con mi monitor externo, un ultrasharp dell conectado a través de VGA. (En el momento)

La situación que quiero tener:

  • Monitor desconectado, tapa de laptop abierta: pantalla de laptop
  • Monitor desconectado, tapa del portátil cerrada: suspender / hibernate
  • Monitor conectado, tapa del portátil abierta: dos pantallas una al lado de la otra, por supuesto, con máx. solución. El monitor externo debe ser la pantalla principal.
  • Monitor conectado, tapa de la computadora portátil cerrada: monitor externo como monitor principal, pantalla de la computadora portátil apagada.

Eso solía funcionar en mi mac bastante bien; Cuando cerré la tapa, hibernó, pero pude activarlo tecleando el teclado mientras la computadora portátil estaba cerrada y el monitor externo mostraba la imagen.

Ahora, tengo varios problemas con Ubuntu.

  • Conectar el monitor mientras la computadora portátil está funcionando produce imágenes malas, el monitor está parpadeando y tengo que tirar del cable. Cuando el monitor está conectado durante el arranque, funciona en paralelo
  • Unidad : cuando cierro la computadora portátil, todo se vuelve negro y ya no reactjs, aunque en la configuración de energía del sistema establezco el comportamiento en “pantalla en blanco”. Al abrir la computadora portátil nuevamente, se obtiene una imagen en negro en ambos monitores, solo se ve la flecha del mouse. Pero todavía nada reactjs y tengo que reiniciar el portátil manualmente.
  • Clásico de Ubuntu : aquí, cuando cierro el portátil, el monitor externo muestra el escritorio, pero en mala resolución. En la configuración del monitor, reconozco que el sistema cree que es el monitor de la computadora portátil. (detectar monitores) Después de abrir la computadora portátil de nuevo, se vuelve negra como cuando se está ejecutando la unidad y tengo que reiniciar.

Después de algunos googeling, siento que otras personas tienen los mismos problemas al usar natty. ¿Qué podría hacer al respecto?

Lo resolví utilizando un antiguo kernel 2.6.37. Aparentemente, la nueva twig 2.6.38 tiene problemas con los chips Arrandale.